Kit #33 working great

This topic contains 3 replies, has 2 voices, and was last updated by  k4lnn 5 months, 1 week ago.

  • Author
    Posts
  • #587

    k4lnn
    Participant

    Well, I’ve been having a great time using my Enigma which works great. No issues except for aminor one – the N plug was not working. I traced it to a bad (or nonexistent) solder joint on pin 28 of the MCP23017 port expander. Soldered up the pin and problem solved. I’ve been having a lot of fun encrypting and decrypting messages and having had no previous Arduino experience, I got curious and started studying all about programming and using the Arduino. I was able to write some pretty cool (I think) programs for different things and one of my favorites is a morse code program transmit on my ham radios using the serial monitor.

    I do have a question, though. I tried to upload the v1.05 software to a Nano chip and could not get it to verify or upload. I keep getting an error that says “Error compiling for board Arduino Nano”. All the setting on the IDE are correct. I have no idea why it won’t compile and upload. I was thinking maybe because I didn’t have the libraries added yet? I was wondering if you could give instructions on how to upload new software versions, step by step, or possibly a hint as to what I am doing wrong.

  • #588

    me2016
    Keymaster

    For a start – sorry that the N plug didn’t work. I did ring it up but it was before I had a good test jig so I must have pushed down the pin or something when I tested it.

    As for uploading your own software, it is a few steps but they are not that tricky. Hard to diagnose without the first part of the message but I’m guessing it complains about some missing files.
    Jeff Tranter did a serie of blogposts around meinenigma and the software part starts at
    http://jefftranter.blogspot.com/2017/04/the-meinenigma-enigma-machine-kit_8.html.
    The very high level is that you need to
    1 – download and install the arduino IDE from https://www.arduino.cc/en/main/software
    2 – Download the meinenigma code from https://github.com/lpaseen/meinEnigma
    (I guess you done 1 & 2 already)
    3 – download two libraries
    HT16K33 Arduino code: https://github.com/lpaseen/ht16k33
    AltSoftSerial Arduino library: https://github.com/PaulStoffregen/AltSoftSerial
    The libraries need to be saved to the arduino library path which is (on windoze) My Documents\Arduino\libraries\. See https://www.arduino.cc/en/Guide/Libraries#toc5 for more details around that.

  • #589

    k4lnn
    Participant

    Thanks for your quick response. I downloaded the two libraries into the Arduino IDE and tried again to compile the code but got the same error message. I’m not sure I downloaded the code properly. I think I just opened up the .ino file and copied and pasted it into the IDE sketchbook. It’s not really important that I get the v1.05 since my Enigma is working just fine and there are really no big changes but I would like to know how to do it for future use. I guess I will have to continue to experiment with it. Any other thoughts would be appreciated, but I know you must be really busy.

    Congratulations on a great project, and I wish you all the success you deserve. I think it is a fantastic kit and I don’t hesitate to talk it up to people I know.

  • #590

    k4lnn
    Participant

    OK, I finally got it! I downloaded the zip file again from GitHub and this time it worked! I don’t know what happened before but it compiles now with no errors. Thanks for your help.

You must be logged in to reply to this topic.


Archives

Recent Comments

    Categories

    • No categories